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Chương I. Khái niệm về cơ sở dữ liệu và hệ quản trị cơ sở dữ liệu
Bài 1. Khái niệm cơ sở dữ liệu
A. Tóm tắt lý thuyết
1. 
hồ sơ: Sắp xếp hồ sơ. Tìm kiếm các thông tin thỏa mãn một số điều kiện nào đó. Tính toán thống kê để đưa ra các thông tin đặc trưng. Lập báo cáo để tạo lập một bộ hồ sơ mới có cấu trúc và khuôn dạng theo yêu cầu cụ thể.
3. Hệ cơ sở dữ liệu
a) Khái niệm CSDL và Hệ QTCSDL:
- Cơ sở dữ liệu là một tập hợp các dữ liệu có liên quan với nhau, chứa thông tin của một tổ chức nào đó, được lưu trữ trên các thiết bị nhớ để đáp ứng nhu cầu khai thác thông tin của nhiều người dùng với nhiều mục đích khác nhau.
- Hệ QTCSDL là phần mềm cung cấp một môi trường thuận lợi và hiệu quả để tạo lập, lưu trữ và khai tác thông tin của CSDL.
- Để lưu trữ và khai thác thông tin bằng máy tính cần phải có: CSDL; Hệ QTCSDL; Các thiết bị vật lí (máy tính, đĩa cứng, mạng,…).
b) Các mức thể hiện Bài toán quản lí: 
Giải quyết các bài toán quản lí thường phải thực hiện các công việc sau:
- Tạo bảng gồm những thông tin về các đối tượng cần quản lí;
- Cập nhật thông tin: sửa chữa, thêm, bớt, …;
- Khai thác thông tin: tìm kiếm, sắp xếp, thống kê, tổng hợp, …
2. Các công việc thường gặp khi xử lí thông tin của tổ chức:
a) Tạo lập hồ sơ: Xác định chủ thể cần quản lí. Xác định cấu trúc hồ sơ. Thu thập, tập hợp thông tin cần quản lí và lưu trữ chúng theo cấu trúc đã xác định.
b) Cập nhật hồ sơ: Sửa chữa hồ sơ. Bổ sung thêm hồ sơ. Xóa hồ sơ của đối tượng mà tổ chức không còn quản lí. 
c) Khai thác của CSDL: mức vật lí; mức khái niệm; mức khung nhìn
B. Câu hỏi trắc nghiệm
Câu 1: Công việc thường gặp khi xử lí thông tin của một tổ chức là gì?
A. Tạo lập hồ sơ   B. Cập nhật hồ sơ   C. Khai thác hồ sơ      D. Tạo lập, cập nhật, khai thác hồ sơ
Câu 2: Cần tiến hành cập nhật hồ sơ học sinh của nhà trường trong các trường hợp nào sau đây?
A. Một học sinh mới chuyển từ trường khác đến; thông tin về ngày sinh của một học sinh bị sai.
B. Sắp xếp danh sách học sinh theo thứ tự tăng dần của tên
C. Tìm học sinh có điểm môn toán cao nhất khối.
D. Tính tỉ lệ học sinh trên trung bình môn Tin của từng lớp.
Câu 3: Dữ liệu trong một CSDL được lưu trong:
A. Bộ nhớ RAM             B. Bộ nhớ ROM              C. Bộ nhớ ngoài              D. Các thiết bị vật lí
Câu 4: Việc xác định cấu trúc hồ sơ được tiến hành vào thời điểm nào?
A. Trước khi thực hiện các phép tìm kiếm, tra cứu thông tin
B. Cùng lúc với việc nhập và cập nhật hồ sơ
C. Sau khi đã nhập các hồ sơ vào máy tính               
D. Trước khi nhập hồ sơ vào máy tính
Câu 5: Xét công tác quản lí hồ sơ. Trong số các công việc sau, những việc nào không thuộc nhóm thao tác cập nhật hồ sơ?
A. Xóa một hồ sơ                                           B. Thống kê và lập báo cáo    
C. Thêm hai hồ sơ                                           D. Sửa tên trong một hồ sơ.
Câu 6: Cơ sở dữ liệu (CSDL) là :
A. Tập hợp các dữ liệu chứa đựng các kiểu dữ liệu: ký tự, số, ngày/giờ, hình ảnh,... của một chủ thể nào đó.
B. Tập hợp dữ liệu có liên quan với nhau theo một chủ đề nào đó được ghi lên giấy.
C. Tập hợp dữ liệu có liên quan với nhau theo một chủ đề nào đó được lưu trên máy tính điện tử để đáp ứng nhu cầu khai thác thông tin của nhiều người.
D. Tập hợp dữ liệu có liên quan với nhau theo một chủ đề nào đó được lưu trên giấy để đáp ứng nhu cầu khai thác thông tin của nhiều người.
Câu 7: Hệ quản trị CSDL là:
A. Phần mềm dùng tạo lập, cập nhật, lưu trữ và khai thác thông tin của CSDL
B. Phần mềm dùng tạo lập, lưu trữ một CSDL
C. Phần mềm để thao tác và xử lý các đối tượng trong CSDL
D. Phần mềm dùng tạo lập CSDL
Bài 2. Hệ quản trị cơ sở dữ liệu
A. Tóm tắt lý thuyết
1. Các chức năng của Hệ QTCSDL:
a) Cung cấp môi trường tạo lập CSDL: để người dùng dễ dàng khai báo kiểu dữ liệu, các cấu trúc dữ liệu thể hiện thông tin và các ràng buộc trên dữ liệu.
Mỗi Hệ QTCSDL cung cấp một hệ thống các kí hiệu để mô tả CSDL gọi là ngôn ngữ định nghĩa dữ liệu.
b) Cung cấp môi trường cập nhật và khai thác dữ liệu: ngôn ngữ để người dùng diễn tả yêu cầu cập nhật và khai thác thông tin gọi là ngôn ngữ thao tác dữ liệu. Gồm cập nhật (nhập, sửa, xóa dữ liệu) và khai thác (sắp xếp, tìm kiếm, kết xuất báo cáo,…).
c) Cung cấp công cụ kiểm soát, điều khiển truy cập vào CSDL: Hệ QTCSDL phải có các bộ chương trình thực hiện nhiệm vụ sau: Phát hiện và ngăn chặn sự truy cập không được phép. Duy trì nhất quán của dữ liệu. Tổ chức và điều khiển các truy cập đồng thời. Khôi phục CSDL khi có sự cố ở phần cứng hay phần mềm. Quản lí các mô tả dữ liệu.
2. Vai trò của con người khi làm việc với Hệ QTCSDL:
a) Người quản trị CSDL: chịu trách nhiệm quản lí các tài nguyên như CSDL, hệ QTCSDL và các phần mềm liên quan. Có vai trò quản lí tài nguyên; cài đặt CSDL vật lí, cấp phát quyền truy cập, cấp phần mềm và phần cứng theo yêu cầu; duy trì hoạt động hệ thống.
b) Người lập trình ứng dụng: là người có nhiệm vụ xây dựng các chương trình ứng dụng đáp ứng nhu cầu khai thác của nhóm người dùng.
c) Người dùng: là người có nhu cầu khai thác thông tin từ CSDL.
3. Các bước xây dựng CSDL:
- Bước 1. Khảo sát;
- Bước 2. Thiết kế
- Bước 3. Kiểm thử
B. Câu hỏi trắc nghiệm
Câu 1: Ngôn ngữ định nghĩa dữ liệu bao gồm các lệnh cho phép:
A. Đảm bảo tính độc lập dữ liệu
B. Khai báo kiểu dữ liệu, cấu trúc dữ liệu và các ràng buộc trên dữ liệu của  CSDL
C. Mô tả các đối tượng được lưu trữ trong CSDL
D. Khai báo kiểu dữ liệu của CSDL
Câu 2: Ngôn ngữ thao tác dữ liệu thật chất là:
A. Ngôn ngữ để người dùng diễn tả yêu cầu cập nhật hay khai thác thông tin
B. Ngôn ngữ để người dùng diễn tả yêu cầu cập nhật thông tin
C. Ngôn ngữ SQL
D. Ngôn ngữ bậc cao
Câu 3: Những nhiệm vụ nào dưới đây không thuộc nhiệm vụ của công cụ kiểm soát, điều khiển truy cập vào CSDL?
A. Duy trì tính nhất quán của CSDL        B. Cập nhật (thêm, sửa, xóa dữ liệu)
C. Khôi phục CSDL khi có sự cố             D. Phát hiện và ngăn chặn sự truy cập không được phép
Câu 4: Người nào đã tạo ra các phần mềm ứng dụng đáp ứng nhu cầu khai thác thông tin từ CSDL?
A. Người dùng                                                          B. Người  lập trình ứng dụng
C. Người QT CSDL                                                 D. Cả ba người trên
Câu 5: Người nào có vai trò quan trọng trong vấn đề phân quyền hạn truy cập sử dụng CSDL?
A. Người lập trình                                                     B. Người dùng
C. Người quản trị                                                      D. Nguời quản trị CSDL
Câu 6: Trong vai trò của con người khi làm việc với các hệ CSDL, người thiết kế và cấp phát quyền truy cập cơ sở dữ liệu, là người ?
A. Người lập trình ứng dụng                    B. Người sử dụng (khách hàng)
C. Người quản trị cơ sở dữ liệu                D. Người bảo hành các thiết bị phần cứng của máy tính
Câu 7: Quy trình xây dựng CSDL là:
A. Khảo sát → Thiết kế → Kiểm thử                         B. Khảo sát → Kiểm thử → Thiết kế
C. Thiết kế → Kiểm thử → Khảo sát                         D. Thiết kế → Khảo sát → Kiểm thử

Chương II. Hệ quản trị cơ sở dữ liệu Microsoft Access
Bài 3. Giới thiệu Microsoft Access
A. Tóm tắt lý thuyết
1. Phần mềm Microsoft Access là hệ quản trị cơ sở dữ liệu nằm trong bộ phần mềm Microsoft Office dành cho máy tính.
2. Khả năng của Access: cung cấp các công cụ tạo lập, lưu trữ, cập nhật và khai thác dữ liệu.
3. Các loại đối tượng chính của Access:
- Bảng (table) dùng để lưu trữ dữ liệu. Mỗi bảng chứa thông tin về một chủ thể xác định và bao gồm nhiều hàng, mỗi hàng chứa các thông tin về một cá thể xác định của chủ thể đó.
- Mẩu hỏi (query) dùng để sắp xếp, tìm kiếm và kết xuất dữ liệu xác định từ một hoặc nhiều bảng.
- Biểu mẩu (form) giúp tạo giao diện thuận tiện cho việc nhập hoặc hiển thị thông tin.
- Báo cáo (report) được thiết kế để định dạng, tính toán, tổng hợp các dữ liệu được chọn và in ra.
4. Một số thao tác cơ bản:
- Khởi động Access
- Tạo cơ sở dữ liệu mới: chọn File → New…, chọn Blank Database, nhập tên, chọn Create
- Mở CSDL đã có: chọn File → Open…  (file Access có phần mở rộng là .mdb)
- Kết thúc phiên làm việc với Access: chọn File → Exit
- Làm việc với các đối tượng: 
* Bao gồm 2 chế độ làm việc là thiết kế (Design View) và trang dữ liệu (Datasheet View). Chọn menu View → Design View hoặc menu View →  Datasheet View.
* Mỗi đối tượng có thể tạo bằng nhiều cách khác nhau: Dùng các mẫu dựng sẵn (wizard-thuật sĩ); Người dùng tự thiết kế; Kết hợp cả hai cách trên.
B. Câu hỏi trắc nghiệm
Câu 1: Access có những khả năng nào?
A. Cung cấp công cụ tạo lập, lưu trữ dữ liệu           
B. Cung cấp công cụ tạo lập, cập nhật và khai thác dữ liệu
C. Cung cấp công cụ tạo lập, lưu trữ và khai thác dữ liệu
D. Cung cấp công cụ tạo lập, lưu trữ, cập nhật và khai thác dữ liệu
Câu 2: Các đối tượng cơ bản trong Access là:
A. Bảng, Macro, Biểu mẫu, Mẫu hỏi                        B. Bảng, Macro, Biểu mẫu, Báo cáo
C. Bảng, Mẫu hỏi, Biểu mẫu, Báo cáo                      D. Bảng, Macro, Môđun, Báo cáo
Câu 3: Để định dạng, tính toán, tổng hợp và in dữ liệu, ta dùng:
A. Table                              B. Form                          C. Query                        D. Report
Câu 4: Để sắp xếp, tìm kiếm và kết xuất dữ liệu xác định từ một hoặc nhiều bảng, ta dùng:
A. Table                              B. Form                          C. Query                        D. Report
Câu 5: Đối tượng nào tạo giao diện thuận tiện cho việc nhập hoặc hiển thị thông tin?
A. Table                              B. Form                          C. Query                        D. Report
Câu 6: Trong Access, để tạo CSDL mới, thao tác thực hiện lệnh nào sau đây là đúng?
A. Create Table in Design View                                  B. Create table by using wizard
C. File/open                                                                  D. File/New/Blank Database
Câu 7: Tên của CSDL trong Access bắt buộc phải đặt trước hay sau khi tạo CSDL?
A. Đặt tên tệp sau khi đã tạo CSDL                  B. Vào File /Exit
C. Vào File /Close                                             D. Bắt buộc vào là đặt tên tệp rồi mới tạo CSDL 
Câu 8: Có mấy chế độ chính để làm việc với các loại đối tượng?
A. 5 chế độ                          B. 3 chế độ                      C. 4 chế độ                  D. 2 chế độ
Câu 9: Hai chế độ chính làm việc với các đối tượng là:
A. Trang dữ liệu và thiết kế                                          B. Chỉnh sửa và cập nhật     
C. Thiết kế và bảng                                                       D. Thiết kế và cập nhật
Câu 10: Chế độ thiết kế được dùng để:
A. Tạo mới hay thay đổi cấu trúc của bảng, mẫu hỏi; thay đổi cách trình bày và định dạng biểu mẫu, báo cáo
B. Cập nhật dữ liệu cho của bảng, mẫu hỏi; thay đổi cách trình bày và định dạng biểu mẫu, báo cáo
C. Tạo mới hay thay đổi cấu trúc của bảng, mẫu hỏi; hiển thị dữ liệu của biểu mẫu, báo cáo
D. Tạo mới hay thay đổi cấu trúc của bảng, mẫu hỏi, biểu mẫu và báo cáo
Câu 11: Chế độ trang dữ liệu được dùng để:
A. Tạo mới hay thay đổi cấu trúc của bảng, mẫu hỏi; thay đổi cách trình bày và định dạng biểu mẫu, báo cáo
B. Cập nhật dữ liệu cho của bảng, mẫu hỏi; thay đổi cách trình bày và định dạng biểu mẫu, báo cáo
C. Hiển thị dữ liệu của biểu mẫu, báo cáo; thay đổi cấu trúc bảng, mẫu hỏi
D. Hiển thị dữ liệu dạng bảng, cho phép xem, xóa hoặc thay đổi các dữ liệu đã có
Câu 12: Một đối tượng trong Access có thể được tạo ra bằng cách:
A. Người dùng tự thiết kế, dùng thuật sĩ hoặc kết hợp cả 2 cách trên          
B. Người dùng tự thiết kế
C. Kết hợp thiết kế và thuật sĩ                                                                                    
D. Dùng các mẫu dựng sẵn
Bài 4. Cấu trúc bảng
A. Tóm tắt lý thuyết
1. Các khái niệm chính:
- Bảng gồm các cột (trường – field) và các hàng (bản ghi – record) để chứa toàn bộ dữ liệu mà người dùng cần để khai thác.
- Trường (field): là một cột của bảng thể hiện một thuộctính của chủ thể cần quản lí
- Bản ghi (record): Mỗi bản ghi là một hàng của bảng gồm dữ liệu về các thuộc tính của chủ thể được quản lí.
- Kiểu dữ liệu (Data type): là kiểu của dữ liệu lưu trong một trường. Mỗi trường có một dữ liệu.
2. Tạo và sửa cấu trúc bảng:
a) Tạo cấu trúc bảng:
- bước 1: Chọn Create, chọn Table Design;
- bước 2: Nhập các thông số: Tên trường (field name); chọn kiểu dữ liệu; mô tả nội dung; các tính chất của trường như field size, format, caption, default value,…
- bước 3: chỉ định khóa chính Primary Key
- bước 4: lưu cấu trúc bảng, chọn File → save .
b) Thay đổi cấu trúc bảng: thay đổi thứ tự các trường; thêm, xóa trường; thay đổi khóa chính
c) Xóa và đổi tên bảng.
B. Câu hỏi trắc nghiệm
Câu 1: Trong các phát biểu sau, phát biểu nào sai?
A. Trường (field): bản chất là cột của bảng, thể hiện thuộc tính của chủ thể cần quản lý
[bookmark: _GoBack]B. Bản ghi (record): bản chất là hàng của bảng, gồm dữ liệu về các thuộc tính của chủ thể được quản lý
C. Kiểu dữ liệu (Data Type): là kiểu của dữ liệu lưu trong một trường
D. Một trường có thể có nhiều kiểu dữ liệu
Câu 2: Trong Access, một bản ghi được tạo thành từ dãy:
A.Trường                    B.Cơ sở dữ liệu                      C.Tệp                          D.Bản ghi khác
Câu 3: Phát biểu nào sau là đúng nhất ?
A. Record  là tổng số hàng của bảng                        B. Data Type là kiểu dữ liệu trong một bảng
C. Table gồm các cột và hàng                                   D. Field là tổng số cột trên một bảng
Câu 4: Trong Access, khi nhập dữ liệu cho bảng, giá trị của field GIOI_TINH là True. Khi đó field GIOI_TINH được xác định kiểu dữ liệu gì ?
A.Yes/No                    B.Boolean                               C.True/False                D.Date/Time
Câu 5: Khi chọn kiểu dữ liệu cho trường THÀNH_TIỀN (bắt buộc kèm theo đơn vị tiền tệ), phải  chọn loại nào?
A. Number                          B. Currency                   C. Text                           D. Date/time
Câu 6: Trong Access, dữ liệu kiểu ngày tháng được khai báo bằng:
A. Day/Type                       B. Date/Type                 C. Day/Time                   D. Date/Time
Câu 7: Cửa sổ cấu trúc bảng được chia làm những phần nào?
A. Phần định nghĩa trường và phần các tính chất của trường
B. Tên trường (Field Name), kiểu dữ liệu (Data Type) và mô tả trường (Description)
C. Tên trường (Field Name), kiểu dữ liệu (Data Type) và các tính chất của trường (Field Properties)
D. Tên trường (Field Name), kiểu dữ liệu (Data Type), mô tả trường (Description) và các tính chất của trường (Field Properties)
Câu 8: Phát biểu nào sau đây là sai?
A. Phần định nghĩa trường gồm có: tên trường, kiểu dữ liệu và mô tả trường
B. Mô tả nội dung của trường bắt buộc phải có
C. Cấu trúc của bảng được thể hiện bởi các trường
D. Mỗi trường có tên trường, kiểu dữ liệu, mô tả trường và các tính chất của trường
Câu 9: Khi làm việc với cấu trúc bảng, để xác định tên trường, ta gõ tên trường tại cột:
A. File Name                      B. Field Name               C. Name Field                D. Name
Câu 10: Khi thiết kế xong bảng, nếu không chỉ định khóa chính thì:
A. Access đưa lựa chọn là tự động tạo trường khóa chính cho bảng có tên là ID với kiểu dữ liệu là AutoNumber
B. Access không cho phép lưu bảng
C. Access không cho phép nhập dữ liệu
D. Dữ liệu của bảng sẽ có hai hàng giống hệt nhau
Bài 5. Các thao tác cơ bản trên bảng
A. Tóm tắt lý thuyết
1. Cập nhật dữ liệu:
- Cập nhật dữ liệu là thay đổi dữ liệu trong các bảng gồm: thêm bản  ghi mới, chỉnh sửa, xác các bản ghi.
- Thêm bản ghi mới (insert → new record); xóa (delete) ở chế độ hiện thị trang dữ liệu.
2. Sắp xếp và lọc:
a) Sắp xếp: sắp xếp tăng dần hoặc giảm dần các bản ghi dựa trên giá trị của trường được chọn.
b) Lọc: cho phép tìm ra những bản ghi thỏa mãn một số điều kiện nào đó phục vụ tìm kiếm. Bao gồm 2 cách lọc: lọc theo ô dữ liệu đang chọn hoặc lọc theo mẫu.
3. Tìm kiếm đơn giản: chọn Edit → Find… 
4. In dữ liệu. 
B. Câu hỏi trắc nghiệm
Câu 1: Chế độ nào cho phép thực hiện cập nhật dữ liệu trên bảng một cách đơn giản?
A. Chế độ hiển thị trang dữ liệu                                 B. Chế độ biểu mẫu
C. Chế độ thiết kế                                                       D. Một đáp án khác
Câu 2: Trong khi nhập dữ liệu cho bảng, muốn xóa một bản ghi đã được chọn, ta bấm phím:
A. Enter                              B. Space                         C. Tab                            D. Delete
Câu 3: Bảng đã được hiển thị ở chế độ trang dữ liệu, với một trường đã chọn, muốn sắp xếp các bản ghi theo thứ tự tăng,  thao tác thực hiện lệnh nào sau đây là đúng?
A. Record/Sort/Sort Descending                              B. Insert/New Record
C. Edit/ Sort Ascending                                            D. Record/Sort/Sort Ascending
Câu 4: Khẳng định nào sau đây là sai?
A. Lọc là một công cụ của hệ QT CSDL cho phép tìm ra những bản ghi thỏa mãn một số điều kiện nào đó phục vụ tìm kiếm
B. Lọc tìm được các bản ghi trong nhiều bảng thỏa mãn với điều kiện lọc
C. Sử dụng lọc theo ô dữ liệu đang chọn để tìm nhanh các bản ghi có dữ liệu trùng với ô đang chọn
D. Sử dụng lọc theo mẫu để tìm các bản ghi thỏa mãn các tiêu chí phức tạp
Câu 5: Trong Access, từ Filter có ý nghĩa gì ?
A. Tìm kiếm dữ liệu                B. Lọc dữ liệu             C. Sắp xếp dữ liệu                  D. Xóa dữ liệu
Câu 6: Trên Table ở chế độ Datasheet View, Nhấn Ctrl+F:
A. Mở hộp thoại Font                                     B. Mở hộp thoại Filter           
C. Mở hộp thoại Sort                                      D. Mở hộp thoại Find and Replace
Câu 7: Trong Access, muốn xem lại trang dữ liệu trước khi in, ta thực hiện :
A. File – Print Preview                                                       B. View – Print Preview  
C. Windows – Print Preview                                              D. Tools – Print Preview

Bài 6: Biểu mẫu
1. Khái niệm về biểu mẫu : Biểu mẫu là một đối tượng trong Access được thiết kế để :
	- Hiển thị dữ liệu trong bảng dưới dạng thuận lợi để xem, nhập, và sửa dữ liệu.
	- Thực hiện các thao tác thông qua các nút lệnh do người thiết kế tạo ra.
2. Tạo biểu mẫu mới : 
	- Dùng một trong hai cách sau :
		+ Cách 1 : Nháy đúp vào Create form in Design view để tự thiết kế biểu mẫu
		+ Cách 2 : Nháy đụp vào Create form by using wizard để dùng thuật sĩ.
	- Xét cách kết hợp cả việc dùng thuật sĩ và tự thiết kế để tạo biểu mẫu :
		+ Nháy đúp Create form by using wizard,
		+ Trong hộp thoại Form Wizard :
			- Chọn bảng (hoặc mẫu hỏi) từ ô Tables / Queries.
			- Chọn các trường đưa vào biểu mẫu từ ô Available Fileds.
			- Nháy Next để tiếp tục.
		+ Trong các bước tiếp theo, chọn cách bố trí biểu mẫu rồi chọn kiểu cho biểu mẫu.
		+ Gõ tên cho biểu mẫu. Chọn Open the form to view or enter information để xem hoặc nhập dữ liệu hoặc chọn Modify the form’s design để sửa thiết kế biểu mẫu. Chọn Finish để kết thúc.
	* Chỉnh sửa biểu mẫu trong chế độ thiết kế : chuyển sang chế độ thiết kế để thay đổi hình thức biểu mẫu. Ta có thể thực hiện : thay đổi nội dung tiêu đề, sử dụng font tiếng Việt, thay đổi kích thước trường, di chuyển trường.
3. Các chế độ làm việc với biểu mẫu :
	a. Chế độ biểu mẫu : có giao diện thân thiệt, thường dùng để cập nhật dữ liệu. Để làm việc trong chế độ này, ta thực hiện :
		- Cách 1 : nháy đúp chuột lên tên biểu mẫu.
		- Cách 2 : chọn biểu mẫu rồi nháy nút Open.
		- Cách 3 : Nháy biểu tượng trên thanh công cụ nếu đang ở chế độ thiết kế.
	b. Chế độ thiết kế : có thể thiết kế mới, xem hay sửa đổi thiết kế cũ của biểu mẫu. Ta có thể thực hiện 1 số thao tác trong chế độ này như : thêm, bớt, thay đổi vị trí, kích thước các trường, định dạng font chữ, tạo nút lệnh. Để làm việc trong chế độ này, ta thực hiện :
		- Cách 1 : Chọn biểu mẫu rồi nháy nút Design trên thanh công cụ.
		- Cách 2 : Nháy nút Design nếu đang ở chế độ biểu mẫu.

Bài 7: Liên kết bảng
1. Khái niệm :
	- Trong CSDL, các bảng thường có liên quan với nhau. Khi xây dựng CSDL, liên kết được tạo ra giữa các bảng cho phép tổng hợp dữ liệu từ nhiều bảng.
	- Để dữ liệu không bị dư thừa thì trong thiết kế cơ sở dữ liệu cần phải tách một bảng thành nhiều bảng. Tuy nhiên để dữ liệu đảm bảo tính nhất quán thì cần phải liên kết các bảng.
2. Kĩ thuật tạo liên kết :
	- Mở cửa sổ Relationships bằng cách vào Tool / Relationships.
	- Click phải chuột vào vùng trống trong cửa sổ Relationships và chọn Show Table …
	- Trong hộp thoại Show Table chọn các bảng cần tạo liên kết bằng cách chọn tên bảng rồi nháy Add. Nháy Close để đóng cửa sổ Show Table.
	- Di chuyển các bảng sao cho hiển thị toàn bộ chúng trên cửa sổ.
	- Kéo các trường giống nhau giữa các bảng và chọn OK.
Câu 1: Liên kết giữa các bảng cho phép:
A. Tránh được dư thừa dữ liệu
B. Có thể có được thông tin tổng hợp từ nhiều bảng
C. Nhất quán dữ liệu
D. Cả A, B, C đều đúng

Câu 2: Để tạo liên kết giữa các bảng, ta chọn:
A.Tool/ Relationships hoặc nháy nút
B.Tool/ Relationships
C.Edit/ Insert/ Relationships
D.Tất cả đều đúng

Câu 3: Sắp xếp các bước theo đúng thứ tự thực hiện để tạo liên kết giữa hai bảng:
1. Kéo thả trường khóa làm liên kết từ bảng phụ tới bảng chính( trường khóa làm khóa chính)
2. Chọn các tham số liên kết
3. Hiển thị hai bảng (các trường) muốn tạo liên kết
4. Mở cửa sổ Relationships
A. 2→4→1→3     B. 4→1→2      C. 4→2→3→1      D. 3→1→4→2

Câu 4: Trong Access, để tạo liên kết giữa 2 bảng thì hai bảng đó phải có hai trường thỏa mãn điều kiện:
A. Có tên giống nhau
B. Có kiểu dữ liệu giống nhau
C. Có ít nhất một trường là khóa chính
D. Cả A, B, C

Câu 5: Điều kiện cần để tạo được liên kết là:
A. Phải có ít nhất hai bảng
B. Phải có ít nhất một bảng và một mẫu hỏi
C. Phải có ít nhất một bảng mà một biểu mẫu
D. Tổng số bảng và mẫu hỏi ít nhất là 2

Câu 6: Điều kiện để tạo mối liên kết giữa hai bảng là :
A. Trường liên kết của hai bảng phải cùng kiểu dữ liệu
B. Trường liên kết của hai bảng phải là chữ hoa
C. Trường liên kết của hai bảng phải là kiểu dữ liệu số
D. Trường liên kết của hai bảng phải khác nhau về kiểu dữ liệu

Câu 7: Tại sao khi lập mối quan hệ giữa hai trường của hai bảng nhưng Access lại không chấp nhận
A. Vì bảng chưa nhập dữ liệu
B. Vì một hai bảng này đang sử dụng (mở cửa sổ table)
C. Vì hai trường tham gia vào dây quan hệ khác kiểu dữ liệu(data type), khác chiều dài (field size)
D. Các câu B và C đều đúng

Câu 8: Khi liên kết bị sai, ta có thể sửa lại bằng cách chọn đường liên kết cần sửa, sau đó:
A. Nháy đúp vào đường liên kết  chọn lại trường cần liên kết
B. Edit → RelationShip
C. Tools → RelationShip → Change Field
D. Chọn đường liên kết giữa hai bảng đó và nhấn phím Delete

Câu 9: Muốn xóa liên kết giữa hai bảng, trong cửa sổ Relationships ta thực hiện:
A. Chọn hai bảng và nhấn phím Delete
B. Chọn đường liên kết giữa hai bảng đó và nhấn phím Delete
C. Chọn tất cả các bảng và nhấn phím Delete
D. Cả A, B, C đều sai
Câu 10: Để xóa liên kết, trước tiên ta chọn liên kết cần xóa. Thao tác tiếp theo nào sau đây là sai?
A. Bấm Phím Delete → Yes
B. Click phải chuột, chọn Delete  Yes
C. Edit → Delete → Yes
D. Tools → RelationShip → Delete → Yes

Bài 8: Truy vấn dữ liệu
1. Các khái niệm : 
	a. Mẫu hỏi (truy vấn) : 
		- Mẫu hỏi được dùng dựa vào liên kết giữa các bảng, ta có thể thống kê dữ liệu, nhóm và lụa chọn các bản ghi của nhiều bảng theo các điều kiện cho trước.
		- Mẫu hỏi thường được sử dụng để :
			+ Sắp xếp các bản ghi.
			+ Chọn các bản ghi thỏa mãn các điều kiện cho trước.
			+ Chọn các trường để hiển thị.
			+ Thực hiện tính toán như tính trung bình cộng, tính tổng, đếm bản ghi, ...
			+ Tổng hợp và hiển thị thông tin từ nhiều bảng hoặc mẫu hỏi khác nhau.
		- Có hai chế độ làm việc : chế độ thiết kế và chế độ trang dữ liệu.
	b. Biểu thức :
		- Để thực hiện các tính tóan và kiểm tra các điều kiện, ta phải biết cách viết các biểu thức đó. Các biểu thức trong Access là :
			+ Các phép tóan thường dùng bao gồm :
				- Phép toán số học : +, -, *, /
				- Phép toán so sánh : <, >, <=, >=, =, <>
				- Phép toán logic : AND (và), OR (hoặc), NOT (phủ định).
				- Phép toán ghép chuỗi : &
			+ Các toán hạng được viết trong biểu thức :
				- Tên trường : được viết trong cặp dấu [ ]
				- Hằng số : 200, 12 ...
				- Hằng văn bản (các ký tự) phải được viết trong cặp dấu kép “ ”
				- Các hàm : như SUM, AVG ...
			+ Biểu thức số học được dùng để mô tả các trường tính toán trong mẫu hỏi.
			+ Biểu thức logic đượng dùng trong các trường hợp : thiết lập bộ lọc cho bảng, thiết lập điều kiện lọc để tạo mẫu hỏi.
	c. Các hàm : Access cung cấp một số hàm thống kê thông dụng áp dụng cho các nhóm, gọi tắt là các hàm hộp nhóm, trong đó có :
		- SUM : tính tổng					- (chỉ thực hiện trên các trường kiểu số)
		- AVG : tính giá trị trung bình	- (chỉ thực hiện trên các trường kiểu số)
		- MIN : tìm giá trị nhỏ nhất		- (chỉ thực hiện trên các trường kiểu số)
		- MAX : tìm giá trị lớn nhất		- (chỉ thực hiện trên các trường kiểu số)
		- COUNT : đếm số giá trị khác trống (null)
2. Tạo mẫu hỏi :
	- Chọn Queries trong bảng chọn đối tượng.
	- Tạo mẫu hỏi mới bằng cách dùng thuật sĩ hay tự thiết kế. Các bước thực hiện :
		+ Chọn dữ liệu nguồn cho mẫu hỏi (bảng, mẫu hỏi khác)
		+ Chọn các trường dữ liệu nguồn để đưa vào mẫu hỏi.
		+ Khai báo các điều kiện cần đưa vào mẫu hỏi để lọc các bản ghi.
		+ Chọn các trường dùng để sắp xếp các bản ghi trong mẫu hỏi.
		+ Tạo các trường tính toán từ các trường đã có.
		+ Đặt điều kiện gộp nhóm.
	- Có hai chế độ thường dùng để làm việc với mẫu hỏi : chế độ thiết kế và chế độ trang dữ liệu.
	- Để xem hay sửa đổi thiết kế mẫu hỏi, ta thực hiện như sau : chọn mẫu hỏi cần xem hay sửa rồi nháy nút Design.
	- Nội dung từng hàng trong cửa sổ mẫu hỏi ở chế độ thiết kế :
		+ Field : khai báo tên các trường. Đó là các trường sẽ có mặt trong mẫu hỏi hoặc các trường chỉ dùng để lọc, sắp xếp, kiểm tra giá trị, ...
		+ Table : tên bảng hay mẫu hỏi chứa trường tương ứng.
		+ Sort : xác định trường cần sắp xếp.
		+ Show : xác định trường xuất hiện trong mẫu hỏi.
		+ Criteria : mô tả điều kiện để chọn các bản ghi đưa vào mẫu hỏi. Các điều kiện được viết dưới dạng biểu thức logic.
	- Khi ở chế độ thiết kế, ta có thể thực hiện mẫu hỏi để xem kết quả bằng cách chọn lệnh View / Datasheet View.
Câu 1: Truy vấn dữ liệu có nghĩa là:
A. In dữ liệu
B. Cập nhật dữ liệu
C. Tìm kiếm và hiển thị dữ liệu
D. Xóa các dữ liệu không cần đến nữa

Câu 2: Nếu những bài toán phức tạp, liên quan tới nhiều bảng, ta sử dụng:
A. Mẫu hỏi     B. Bảng     C. Báo cáo      D. Biểu mẫu

Câu 3: Để hiển thị một số bản ghi nào đó trong cơ sở dữ liệu, thống kê dữ liệu, ta dùng:
A. Mẫu hỏi      B. Câu hỏi      C. Liệt kê      D. Trả lời

Câu 4: Các chế độ làm việc với mẫu hỏi là:
A. Mẫu hỏi
B. Mẫu hỏi và thiết kế
C. Trang dữ liệu và thiết kế
D. Trang dữ liệu và mẫu hỏi

Câu 5: Kết quả thực hiện mẫu hỏi có thể tham gia vào việc tạo ra:
A. Bảng, biểu mẫu, mẫu hỏi hay báo cáo
B. Bảng, biểu mẫu khác, mẫu hỏi khác hay các trang khác
C. Bảng, biểu mẫu, mẫu hỏi khác hay báo cáo
D.Bảng, biểu mẫu, mẫu hỏi khác

Câu 6: “ /” là phép toán thuộc nhóm:
A. Phép toán so sánh
B. Phép toán số học
C. Phép toán logic
D. Không thuộc các nhóm trên

Câu 7: Phát biểu nào sai trong các phát biểu sau khi nói về mẫu hỏi?
A. Biểu thức số học được sử dụng để mô tả các trường tính toán
B. Biểu thức logic được sử dụng khi thiết lập bộ lọc cho bảng, thiết lập điều kiện lọc để tạo mẫu hỏi
C. Hằng văn bản được viết trong cặp dấu nháy đơn
D. Hàm gộp nhóm là các hàm như: SUM, AVG, MIN, MAX, COUNT

Câu 8: Trong lưới QBE của cửa sổ mẫu hỏi (mẫu hỏi ở chế độ thiết kế) thì hàng Criteria có ý nghĩa gì?
A. Mô tả điều kiện để chọn các bản ghi đưa vào mẫu hỏi
B. Xác định các trường xuất hiện trong mẫu hỏi
C. Xác định các trường cần sắp xếp
D. Khai báo tên các trường được chọn

Câu 9: Bảng DIEM có các trường MOT_TIET, HOC_KY. Để tìm những học sinh có điểm một tiết trên 7 và điểm thi học kỳ trên 5 , trong dòng Criteria của trường MOT_TIET, HOC_KY, biểu thức điều kiện nào sau đây là đúng:
A. MOT_TIET > 7 AND HOC_KY >5
B. [MOT_TIET] > 7 AND [HOC_KY]>5
C. [MOT_TIET] > 7 OR [HOC_KY]>5
D. [MOT_TIET] > "7" AND [HOC_KY]>"5"

Câu 10: Bảng DIEM có các trường MOT_TIET, HOC_KY. Trong Mẫu hỏi, biểu thức số học để tạo trường mới TRUNG_BINH, lệnh nào sau đây là đúng:
A. TRUNG_BINH:(2* [MOT_TIET] + 3*[HOC_KY])/5
B. TRUNG_BINH:(2* MOT_TIET + 3*HOC_KY)/5
C. TRUNG_BINH:(2* [MOT_TIET] + 3*[HOC_KY]):5
D. TRUNG_BINH=(2* [MOT_TIET] + 3*[HOC_KY])/5
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